Please or Register to create posts and topics.

Program just crashes.

Hello (again) Joakim,
Here is the copied message from the other topic 🙂

I have a smilar-ish problem. Similar to crashing. I have downloaded and installed astrocalc and when I go in and try to do anything, it crashes. I try to create a new chart, I fill in the date, time etc. and when I hit "Add", I get the Windows 'ding' sound and then the software stops responding. Creating a new group is what I have been luckiest with as when I tried to do it again I was notified the group already existed. Yet there is no trace of it and I have no idea how to find it.
I have uninstalled and re-installed the software twice now. Still no change.
It simply won't work, it opens and If I attempt to do anything else than the aforementioned it just freezes and shuts.
There was no previous version whatsoever issue, this is a new computer.
If there's anything you think you can do, I'd be grateful.

Forgot to add.... hmmm not much actually. I use windows 10, as I've said it's a previously owned computer that was entirely cleaned up and  pepped up for me as a temporary replacement for my actual one that has died. To me it's a new computer, I had to download everything on it.
Knowing the previous owner, it seems very unlikely this computer has ever seen anything astrology related or that it was poorly cleaned up.

Hi Moon,

not much to go on here as it mysteriously crashes without giving you any error message? These are the hardest cases as it basically be anything from conflict with other installed programs, firewall/a-virus program that block system access, without really identify itself, a bug or use case error in play. Often the only way to catch this is to provide you with a specially crafted debug executable that trows an informative message pinpointing the location as it happens. Although, before we get to that let's try something as I'm not quite sure where to effectively place debug code at this stage.

If not to much of a problem for you, could I ask you to start from scratch once again. Uninstall the program and remove the folders "C:\Program Files (x86)\Astrocalc Software" and "Documents\Astrocalc Software" before you install again.

Then Follow these steps:

As program starts and you have closed the hits dialog, click the "New" button. Before you fill out the data fields in the "New Chart" screen, select a group, even if one is selected (just to be certain) and then make sure fields are filled properly. before you click on Add, I would appreciate if you could take a screenshot of the screen to post here as that may give me a hint in case I have missed something in the data validation process. If you get an error message, screenshot it as well.

If you get a crash, don't start to explore on your own as that may change the conditions I need to work something out with.


Hi Joakim,
Thank you so much for your amazing mindset 🙂
I'll get to re-installing as soon as I'm finished working and will post screen shots, no bother.
If following the steps you've indicated doesn't yield anything, would it be relevant to just try getting offline and shutting down my firewall and such during installation ?
The only message I've had so far was Windows' "astrolab has stopped working" with the process of reporting to microsoft which I've let run the first time and then cancelled mid-way as it seemed pointless.
I'll report as precisely as I can so you have the best of that mystery to work from. No extra explorations.
Thank you so much.

Hi Moon,

I think this problem was solved in the release before Christmas, could you confirm this please?